GROW CRM

System Check
system checks failed

The following (minimum system requirements) must be met before you can continue. See documentation for details.



PHP version requirements
PHP Version 7.3 or 7.4
This version of Grow CRM requires PHP 7.3 or 7.4.

You server is currently running PHP 7.2.34

You can easily set/change the required PHP Version inside your web hosting control panel. (see decumentation for help)